Bug #25146

TYPO3 4.5.1: PHP warning in page module (e.g. in TemplaVoila) with active open_basedir

Added by Felix Nagel almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-02-23
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using the page module the below posted error message turns up. Im not quite sure if this is a TV problem but the problem only appears in the TV page module and with TYPO3 4.5.1 (since latest update).

PHP Warning
PHP Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(xxx/typo3/../../../../t3lib/js/extjs/ux/flashmessages.js) is not within the allowed path(s): (/home/www/web42/html/:/home/www/web42/phptmp/:/home/www/webx/files/:/home/www/webx/atd/:/usr/local/php5-fcgi/lib/php/:/usr/local/php5/pear/) in /home/www/webx/html/xxx/t3lib/class.t3lib_compressor.php line 136
(issue imported from #M17728)

17728.diff View (855 Bytes) Administrator Admin, 2011-02-25 23:23

History

#1 Updated by Ernesto Baschny almost 9 years ago

It would be very helpful if you could get a full stack trace on that place. You will get that if you install the php xdebug extension. Thanks!

#2 Updated by Felix Nagel almost 9 years ago

As Im using hosted space Im not able to install PHP modules. Is there any other way to get the information you need?

#3 Updated by Alban Cousinie almost 9 years ago

Same problem on TYPO3 4.5.1 here. No possibility to install xDebug too (sorry).
My error message :
PHP Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/var/www/mysite.fr/httpdocs/typo3/../../../../t3lib/js/extjs/ux/flashmessages.js) is not within the allowed path(s): (/var/www/mysite.fr/httpdocs:/tmp:/var/www/typo3_RSA_auth:/var/log/typo3) in /var/www/mysite.fr/httpdocs/typo3_src-4.5.1/t3lib/class.t3lib_compressor.php line 136

#4 Updated by Lars Dyhr almost 9 years ago

I see the same on my setup. This was not present on 4.5.0.
Seems to be related to setups where open_basedir is effect.
Also it seems that the file path that is_file is trying to check is indeed violating open_basedir (as the path points nowhere).
I suspect that this is because the backpath is not yet substituted at this point in code.
However the file is actually included, som for my setup I have just added an "@" in front of the is_file function calls in the method getFilenameFromMainDir.

Don't know if this is the right way or if another check should be pursued in stead.

#5 Updated by Ernesto Baschny almost 9 years ago

Committed to:

- trunk rev. 10642
- TYPO3_4-5 rev. 10643, in time for 4.5.2. ;)

Also available in: Atom PDF