Bug #25150

Fatal error when installing TYPO3 with PHP-APC (no session is stored)

Added by Ernesto Baschny almost 9 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-02-24
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When installing TYPO3 together on a system with loaded PHP-APC, e.g. the one that ships with Debian Squeeze (APC 3.1.3, but affected seems to be also 3.1.4-dev, 3.1.3p1, 3.1.2, 3.0.19) you get a Fatal error.

On the first step of the install tool:

Fatal error: Class 't3lib_div' not found in /../typo3/sysext/install/mod/class.tx_install_session.php on line 347

See screen in the attachment (Fatal Error on the bottom).

No further steps are then possible (you then get a login screen).

It turns out that the list of loaded classes is incomplete when PHP tries to write the session data. t3lib_div is not there anymore. This behaviour was introduced in #24980.

The PHP bug is already documented and acknoledged by PHP / APC authors:

http://pecl.php.net/bugs/bug.php?id=16721

From the comment from Rasmus

[2011-02-14 16:44 UTC] rasmus at php dot net

Once again, the fix is trivial. Put session_write_close() in
your script when you are done with the session.

We'll come up with a fix eventually, but it isn't a trivial
thing to fix.

Calling session_write_close() at the destructor of the tx_install_session class seems to be the most easy solution.
(issue imported from #M17732)

fatal-ip451.png View (54.6 KB) Administrator Admin, 2011-02-24 09:09

17732.patch View (1.18 KB) Administrator Admin, 2011-02-24 09:15


Related issues

Related to TYPO3 Core - Bug #25379: Install Tool login not possible after update to 4.4.7 Closed 2011-03-23
Duplicated by TYPO3 Core - Bug #25273: Fatal error: spl_autoload() : Class t3lib_div could not be loaded Closed 2011-03-07

History

#1 Updated by Ernesto Baschny almost 9 years ago

Committed to:

- trunk, rev. 10636
- TYPO3_4-5, rev. 10637
- TYPO3_4-4, rev. 10638

Also available in: Atom PDF