Bug #25385

Uploader is not replacing "Umlaute"

Added by Christian Nölle almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-03-24
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The upload routine in TYPO3 is not replacing the german Umlaute any more. This occurs with the flash but also for the old fashioned upload routine.
Once a file is uploaded it is stored with all the Umlaute and this is resulting in errors accessing this file for the users. Furthermore GM is failing to provide a thumbnail - if the file is a picture or a pdf.

If you try to rename that file, the rename routine is properly replacing those characters.

(issue imported from #M18026)


Related issues

Duplicates TYPO3 Core - Bug #22829: Filelist looses first sign of filename if it is an Umlaut Closed 2010-06-07

History

#1 Updated by Christian Nölle almost 9 years ago

The replacement is mentioned in http://bugs.typo3.org/view.php?id=14639 - but is this a bug or a feature. Or even an hidden feature ;D

What is the normal procedure? Prior to 4.5 it was to replace the special characters.... Which I would prefer...

In http://bugs.typo3.org/view.php?id=12661 the thumbnail generation is mentioned concerning folders.

#2 Updated by Christian Nölle almost 9 years ago

Not well thought of....
If you use files with umlaute, as they are not replaced anymore, the corresponding link on a page is marked unaccessible by the link validator as he is escaping those charaters and reporting a 404...

#3 Updated by Chris topher almost 9 years ago

I think that #22829 clearly is a bug.

If special chars are replaced or not depends on $TYPO3_CONF_VARS['SYS']['UTF8filesystem'].
- If set to 0 (which is the default I think) umlauts should get converted.
- If set to 1, umlauts should stay.
Just to be sure: In your installation it is not set to 1, right?

#4 Updated by Christian Nölle almost 9 years ago

Yes, it is set to 1. But then that changed from 4.4 to 4.5 as in 4.4 (iirc) they got replaced. Well, never mind... So someone can please mark this as a duplicate of http://bugs.typo3.org/view.php?id=14639 and close this one as? I will open up a new one for the linkvalidator after I dug deeper into that issue.

#5 Updated by Chris topher almost 9 years ago

Hmm, I don't know if that changed. But you can check that by comparing the default values - you find them in t3lib/config_default.php.

Closed as requested.

Also available in: Atom PDF