Bug #33333

shortcut in other language not working

Added by Kay no-lastname-given over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2012-01-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

i have a website with more than one language... some pages are shortcuts...
my TS:
nav.headerNav = COA
nav.headerNav {
10 = HMENU
10 {
special = list
special.value = 187,28,238,237
1 = TMENU
1 {
wrap = <ul>|</ul>
NO.allWrap = <li>|</li>
NO.stdWrap.wrap = <span>|</span>
ACT < .NO
ACT = 1
}
}
}

with default language the navigation have no problem. but in other languages typo3 don't make an href for shortcut pages.
with no special paramenter in TS, all pages except from type shortcut have a href paramenter in frontend.
4.5.x haven't this problem... so i think is because of clean up the backend code...

i found http://forge.typo3.org/issues/32253 but this not work.


Related issues

Is duplicate of TYPO3 Core - Bug #33428: BE: if create shortcut page translation lose target pageClosed2012-01-25

Actions
Is duplicate of TYPO3 Core - Bug #32406: Menus not working in translated pages for type "shortcut"Closed2011-12-08

Actions
#1

Updated by Ernesto Baschny over 10 years ago

  • Project changed from 1250 to TYPO3 Core
  • Category deleted (Misc)
  • Status changed from New to Accepted

This is clearly a core issue, the "backend code clean-up" project is no longer active.

#2

Updated by Ernesto Baschny over 10 years ago

  • Status changed from Accepted to Closed
#3

Updated by Ernesto Baschny over 10 years ago

  • Category set to Frontend
  • Status changed from Closed to Accepted
  • Complexity set to easy
  • TYPO3 Version set to 4.6

How to reproduce in the intro-package:

- Unter "Examples > Language" create 2 pages "Page 1" and "Page 2"
- Make "Page 1" a shortcut to "Page 2"
- Create translation pages for both pages (Dansk)
- Go to the frontend to the "Examples > Any language" Page
- See both sub-pages are correctly linked
- Switch to "Dansk": First page is not linked correctly anymore (starting with TYPO3 4.6)

#4

Updated by Ernesto Baschny over 10 years ago

Strange enough, this is not a problem in current master (future 4.7) anymore, so somehow it got fixed, but I could localize the fix yet.

#5

Updated by Ernesto Baschny over 10 years ago

  • Status changed from Accepted to Closed

This is a duplicate of #32406, so please let's continue the discussion and potential solution there. Thanks!

Also available in: Atom PDF