Bug #39400

Add field "identifier" to backend_layout

Added by Georg Ringer about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
Start date:
2012-07-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Having an identifier independent to the UID, makes it easier to deal with multiple systems (dev,live,...) which have different records.

Currently backend_layouts are used mostly with

10 = FLUIDTEMPLATE
10 {
    file.stdWrap.cObject = CASE
    file.stdWrap.cObject {
        key.data = levelfield:-1, backend_layout_next_level, slide
        key.override.field = backend_layout

        default = TEXT
        default.value = EXT:fo/Resources/Private/Templates/Page/modern_3col.html
        2 = TEXT
        2.value = EXT:fo/Resources/Private/Templates/Page/modern_2col.html
    }
    layoutRootPath = EXT:fo/Resources/Private/Templates/Page/Layouts/
}

but this makes it hard because the UID of the layout will be different

having an identifier would make it a lot easier, like

10 = FLUIDTEMPLATE
10 {
    file.stdWrap.cObject = RECORDS
    file.stdWrap.cObject {
        tables = backend_layout
        source {
            data = levelfield:-1, backend_layout_next_level, slide
            override.field = backend_layout
        }
        conf.backend_layout = TEXT
        conf.backend_layout {
            value = EXT:fo/Resources/Private/Templates/Page/{identifier}.html
            insertData = 1
        }
    }
    layoutRootPath = EXT:fo/Resources/Private/Templates/Page/Layouts/
}

of course you could still use cObj CASE and use the field identifier as key there.

#1

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13351

#2

Updated by Georg Ringer almost 9 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF