Bug #40339

Autoloader fails for several classes

Added by Nicole Cordes over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2012-08-28
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Due to false path the autoloader doesn't work in several cases.

E.g className Tx_Cars_Controller_CarController is converted to path C:/Users/Nicole/Server/typo3_master.local/typo3conf/ext/cars/Classes/Controller.php (missing class name at the end)

Associated revisions

Revision 7b5a0689 (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Autoloader fails for several classes

Due to false path the autoloader doesn't work in several cases. This patch
attaches the last class name parameter to file path.

Change-Id: Id3a7ee7204944267824f70457d4786c38cd278ec
Fixes: #40339
Related: #40095
Releases: 6.0
Reviewed-on: http://review.typo3.org/14153
Reviewed-by: Jigal van Hemert
Tested-by: Jigal van Hemert
Reviewed-by: Thomas Maroschik
Tested-by: Thomas Maroschik

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14153

#2 Updated by Nicole Cordes over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF