Bug #40843

Fatal error is thrown when more drivers are registered

Added by Nicole Cordes over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2012-09-12
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When multiple drivers are loaded due to extension manager processes the ext_localconf.php's are loaded twice. This leads to exception #1314979451. Instead of checking only the short name of a driver the DriveRegistry should check the class name as well.

Associated revisions

Revision 76ea23d8 (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Fatal error is thrown when more drivers are registered

Due to some extension manager processes when installing a new extension
the DriveRegistry has to support to register the same short name with the
same class name multiple times.

Change-Id: I67e409f532f5736b5a4c0a2e7fb822a579cfaa41
Fixes: #40843
Releases: 6.0
Reviewed-on: http://review.typo3.org/14532
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14532

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14532

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14532

#4 Updated by Nicole Cordes over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF