Bug #41249

tsconfig_help currently broken because of em

Added by Georg Ringer over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2012-09-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

current code of tsconfig_help is


        if (!\TYPO3\CMS\Core\Extension\ExtensionManager::isLoaded('em')) {
            // Em is not loaded, so include the unzip class
            \TYPO3\CMS\Core\Utility\GeneralUtility::requireOnce(PATH_typo3 . 'sysext/em/classes/tools/class.tx_em_tools_unzip.php');
        }
        $unzip = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('tx_em_Tools_Unzip', $file);
        $ret = $unzip->extract(array('add_path' => $path));
        return is_array($ret);

ext is no "extensionmamanager" and unzip is not there anymore


Related issues

Is duplicate of TYPO3 Core - Bug #40191: tsconfig_help is using old emClosed2012-08-25

Actions
Has duplicate TYPO3 Core - Bug #43962: TypoScriptConfigHelpModuleController check for obsolete sysext:emClosed2012-12-13

Actions
#1

Updated by Chris topher almost 8 years ago

  • Status changed from New to Closed

Closed as duplicate of #40191.

Also available in: Atom PDF