Bug #43272

FormWizard does not save

Added by Florian Scholz almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2012-09-12
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

PHP Fatal error: Class '\\TYPO3\\CMS\\Form\\Domain\\Factory\\JsonToTypoScript' not found in /typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4155

Seems like we can't decide how to name "TypoScript" in files and classes...

"JsonToTypoScript" vs
"JsonToTyposcript"

Patch upcoming.

Associated revisions

Revision 7a8f28c5 (diff)
Added by Florian Scholz almost 7 years ago

[BUGFIX] FormWizard does not save

This adds a mapping for the JsonToTyposcript class to resolve
the wrong instantiation due to different versions of file and
class names (Typoscript vs TypoScript).

Resolves: #43272
Releases: 6.0

Change-Id: I9c4eef2547462849e356617e15389976c9c343a6
Reviewed-on: http://review.typo3.org/16715
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16715

#2 Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16715

#3 Updated by Gerrit Code Review almost 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16715

#4 Updated by Gerrit Code Review almost 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16715

#5 Updated by Gerrit Code Review almost 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16715

#6 Updated by Anonymous almost 7 years ago

  • Status changed from Under Review to Resolved

#7 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF