Bug #43362

Language Update Repository Error /Freeze

Added by Sebastian Reinhardt about 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-11-27
Due date:
% Done:

80%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I try to update language (German) from repository, several erros appear an after 3 errors, typo3 shows an errormessage "several erros.. check internetconnection". Then theres no more "action", no downloading

I testet it several times in Firefox 16.0.2, Chrome 23, IE9..
I can't update the language


Files

installtool.png (32.2 KB) installtool.png Joshua Schär, 2014-08-12 08:26
Upgrade Wizard.png (18.9 KB) Upgrade Wizard.png Joshua Schär, 2014-08-12 09:43

Related issues

Related to TYPO3 Core - Bug #62162: TYPO3 mirror vinehosting does not respondClosed2014-10-11

Actions
#1

Updated by Carsten Hager about 9 years ago

Sebastian Reinhardt wrote:

When I try to update language (German) from repository, several erros appear an after 3 errors, typo3 shows an errormessage "several erros.. check internetconnection". Then theres no more "action", no downloading

I testet it several times in Firefox 16.0.2, Chrome 23, IE9..
I can't update the language

Hey Sebastian,

please check ( Reports - Statusbericht ).
PHP Module zip is required!!!!

#2

Updated by Sebastian Reinhardt about 9 years ago

  • % Done changed from 0 to 100

Yes, the problem was a missing php zip extension. now it works!
Thanks for help.
SOLVED

#3

Updated by Florian Carstens almost 9 years ago

  • % Done changed from 100 to 0

Hi there, I ran into the same issue and solved it by adding the zip module. I think, there should be a zip-module-check when accessing the Language menu. Please display a hint or error message informing about this requirement if missing.

#4

Updated by Daniel Ostmann over 8 years ago

Same here. Zip module is installed...

TYPO3 6.1.3
PHP 5.3.

#5

Updated by Daniel Ostmann over 7 years ago

Freshly installed 6.2.4... Same errors.... :-(

#6

Updated by Daniel Ostmann over 7 years ago

Oh, i solved it!

Go to install tool => upgrade wizard and be sure the default extension manager tables are installed! In my case it wasn't. Now it works.

#7

Updated by Joshua Schär over 7 years ago

didnt work for me. got version 6.2.4, zip module is installed, php version 5.5.
what do you mean by "be sure the default extension manager tables are installed"?
php settings like max execution time and so on are set to high values.
also does not work with another typo3 application version 6.1.7.
would be glad to recieve more details. couldnt find anything on google...

#8

Updated by Daniel Ostmann over 7 years ago

Joshua, please go to "Install Tool and then go to the "Upgrade Wizard" and check, if there is a section "install default extension manager tables" (or something like that).

#9

Updated by Joshua Schär over 7 years ago

wow, thx for the quick reply. check the screenshot for what it is that i see in my installtool "upgrade wizard" section.

#10

Updated by Daniel Ostmann over 7 years ago

Ok. Can you migrate the file relations? Maybe you'll see it after that.

#11

Updated by Joshua Schär over 7 years ago

no... see the error message ettached. couldnt solve it until now, there are lots of other people who encounter this error. but no solution worked so far.

#12

Updated by Daniel Ostmann over 7 years ago

Oh, that could be your problem! You database seems to have multiple charsets...

Did you upgraded your installation from a version =< 4.6?

#13

Updated by Daniel Ostmann over 7 years ago

What about #36754?

#14

Updated by Joshua Schär over 7 years ago

  • % Done changed from 0 to 80

HA! it worked! that was the cause... i get some error messages but at least the translation handling works its way all through. even though it takes a lot of time (10'). thx

#15

Updated by Daniel Ostmann over 7 years ago

:-)

#16

Updated by Uwe Urbann about 7 years ago

I still have the same issue with a fresh install of Typo3 6.2.5, everything is okay so far in the install tool. The first few extensions are checked/updated, then one or two errors occur, then the language update process "hangs". I have tried it several times, the errors occur on different extensions, but after one ore two errors the update process does not continue anymore.

#17

Updated by Stephan Großberndt about 7 years ago

I am almost sure this is due to a certain mirror (mirror-typo3.vinehosting.com) which is not available for some time now. If you have the default setting in the extension manager it will randomly select mirrors. If you get vinehosting it fails.

There is a test to use a cloud based repository instead:

http://forum.typo3.org/index.php/t/205810/

So if you execute these MySQL-Statements

TRUNCATE tx_extensionmanager_domain_model_extension;
UPDATE tx_extensionmanager_domain_model_repository SET mirror_list_url='http://repositories.typo3.org/mirrors-cloudfront.xml.gz',last_update=0,extension_count=0;

delete these files
typo3temp/1.extensions.gz
typo3temp/1.mirrors.gz

login to TYPO3 backend, clear caches, go to: ADMIN TOOLS -> Extension Manager -> Get Extensions

fetching the extension list, extensions and translations is much faster and you get no more errors.

Since this is a test the mirrorlist might not always be http://repositories.typo3.org/mirrors-cloudfront.xml.gz so be aware of this if downloads fail you have to restore the original repository by using the static import in the extension manager.

#18

Updated by Uwe Urbann about 7 years ago

It worked, and the translation ist much faster now! Thanks a lot!

#19

Updated by Georg Tiefenbrunn about 7 years ago

Uwe Urbann wrote:

It worked, and the translation ist much faster now! Thanks a lot!

I second that. Thanks for the hint!

#20

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

So... can this be closed?

#21

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF