Bug #46555

Settings for local drivers are not shown by default

Added by Nicole Cordes about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-03-22
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you create a new storage the LocalDriver is selected by default (because it is the first registered driver) but the flexform field is not shown. Because of the hidden configuration field you cannot set up the base path untill you have saved the storage record. Local driver should be selected by default and configuration field should be displayed every time.

Associated revisions

Revision 73ee6ff2 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Settings for local drivers are not shown by default

If you create a new storage the LocalDriver is selected by default
(because it is the first registered driver) but the flexform field is not
shown. Because of the hidden configuration field you cannot set up the
base path until you have saved the storage record. Local driver should be
selected by default and configuration field should be displayed every
time.

Change-Id: Ic9c6c1eb7ca3d9f45723dce728558002440ae9da
Fixes: #46555
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19187
Reviewed-by: Alexander Opitz
Tested-by: Alexander Opitz
Reviewed-by: Andreas Wolf
Tested-by: Andreas Wolf

Revision 1bcedde3 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Settings for local drivers are not shown by default

If you create a new storage the LocalDriver is selected by default
(because it is the first registered driver) but the flexform field is not
shown. Because of the hidden configuration field you cannot set up the
base path until you have saved the storage record. Local driver should be
selected by default and configuration field should be displayed every
time.

Change-Id: Ic9c6c1eb7ca3d9f45723dce728558002440ae9da
Fixes: #46555
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19212
Reviewed-by: Alexander Opitz
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer

History

#1 Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19187

#2 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19187

#3 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19212

#5 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF