Bug #46582

Read permission check for folders is broken

Added by Nicole Cordes about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-03-23
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The read permission check for folders is broken because there are some inconsistencies in naming. For files the action to check is called "read", for folders this check is called "browse". This should be adjusted for folders to be equal to file check and renamed to "read".

Associated revisions

Revision 55876415 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Read permission check for folders is broken

The read permission check for folders is broken because there are some
inconsistencies in naming. For files the action to check is called "read",
for folders this check is called "browse". This should be adjusted for
folders to be equal to file check and renamed to "read".

Change-Id: I80862b60ea7d674df75dee0063764fed95570c6b
Fixes: #46582
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19205
Reviewed-by: Alexander Opitz
Tested-by: Alexander Opitz
Reviewed-by: Tom Ruether
Reviewed-by: Stefan Neufeind
Reviewed-by: Wouter Wolters
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

Revision e467e39f (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Read permission check for folders is broken

The read permission check for folders is broken because there are some
inconsistencies in naming. For files the action to check is called "read",
for folders this check is called "browse". This should be adjusted for
folders to be equal to file check and renamed to "read".

Change-Id: I80862b60ea7d674df75dee0063764fed95570c6b
Fixes: #46582
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19205
Reviewed-by: Alexander Opitz
Tested-by: Alexander Opitz
Reviewed-by: Tom Ruether
Reviewed-by: Stefan Neufeind
Reviewed-by: Wouter Wolters
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter
Reviewed-on: https://review.typo3.org/19625

History

#1 Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19205

#2 Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19625

#3 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF