Bug #46591

Caching framework tables are not generated without a ext_tables.sql

Added by Nicole Cordes over 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Caching
Target version:
Start date:
2013-03-23
Due date:
% Done:

100%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since TYPO3 version 4.6 the caching framework should be responsible to create needed tables for itself. But this is only executed when the extension contains ext_tables.sql file in its extension folder. If you do not need any other tables/fields no caching framework tables are created. This should be independent from ext_tables.sql

Associated revisions

Revision 3cb50eee (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Caching framework tables depends on ext_tables.sql

Since TYPO3 version 4.6 the caching framework should be responsible to
create needed tables for itself. But this is only executed when the
extension contains ext_tables.sql file in its extension folder. If you do
not need any other tables/fields no caching framework tables are created.
This should be independent from ext_tables.sql

Change-Id: Ifba3cb7bcc94d09627b38d5b5962cfdb2282306b
Fixes: #46591
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19214
Reviewed-by: Sascha Egerer
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 3a56664e (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Caching framework tables depends on ext_tables.sql

Since TYPO3 version 4.6 the caching framework should be responsible to
create needed tables for itself. But this is only executed when the
extension contains ext_tables.sql file in its extension folder. If you do
not need any other tables/fields no caching framework tables are created.
This should be independent from ext_tables.sql

Change-Id: Ifba3cb7bcc94d09627b38d5b5962cfdb2282306b
Fixes: #46591
Releases: 6.1, 6.0
Reviewed-on: https://review.typo3.org/19576
Reviewed-by: Nicole Cordes
Tested-by: Nicole Cordes
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19214

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19214

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19214

#4 Updated by Nicole Cordes over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF