Bug #46957

EM: can't install/uninstall extensions

Added by Marcin Sągol over 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2013-04-05
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using latest git version i can't install or uninstall extensions. If i click on Activate icon the main area becames bussy (white overlay) for few seconds and than just extension list is shown. If i try to download new extension it is downloaded but not activated and i can't activate it. Im not sure if it is problem with cache or overal extension manager itself.


Related issues

Related to TYPO3 Core - Bug #54460: Unable to activate extension Closed 2013-12-16
Related to TYPO3 Core - Bug #55252: PHP 5.5 and require LocalConfiguration Closed 2014-01-22

History

#1 Updated by Felix Kopp over 6 years ago

  • Status changed from New to Needs Feedback

I can not confirm this.
Anyone else can confirm?

#2 Updated by Marcin Sągol over 6 years ago

I'll try to investigate this a little bit more. For now i tested Install Tool Upgrade Wizard section and tried to install Recycler and Scheduler from there (Install System Extensions). Sadly no effects - extensions are not installed.

#3 Updated by Marcin Sągol over 6 years ago

From what i see extensions related database tables are created (news, CoolUri). Inside LocalConfiguration.php
file i have their configuration options set:

'EXT' => array(
'extConf' => array(
'cooluri' => 'a:0:{}',
'news' => 'a:0:{}',
'recycler' => 'a:0:{}',
'saltedpasswords' => 'a:0:{}',
'scheduler' => 'a:0:{}',
'sys_action' => 'a:0:{}',
),

but they are not listed in

'EXT' => array(
'extListArray' => array(
...
)
);

#4 Updated by Alexander Opitz over 6 years ago

Hi soee,

did you get your installation working and tried this again as discussed on IRC?

#5 Updated by Marcin Sągol over 6 years ago

Hi Alexander,
no i didn't find solution. On this server i have 3 installations, none is able to install/uninstall extensions. All running the same latest git sources via symlinks.

#6 Updated by Marcin Sągol over 6 years ago

I just finished with reinstalling my VPS and doing configuration from scratch. I can install estensions now so probably it was server configuration problem.

Please close this bug.

#7 Updated by Marcin Sągol over 6 years ago

UPDATE: the reason of the problems was probably Zend Optimizer Plus. I'll check if my configuration was wrong or ZOP itself causes this problems.

#8 Updated by Marcin Sągol over 6 years ago

The problem was caused by Zend Optimizer +.
To make it work i had to set this option: opcache.revalidate_freq= 0

#9 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

Closed as requested, thanks for so much information on the cause.

Also available in: Atom PDF