Bug #47990

FE Error when Upgrading from 4.5.x to 4.5.26

Added by Pascal Querner over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2013-05-06
Due date:
% Done:

0%

Estimated time:
1.00 h
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Hello Core Team,

I was upgrading my TYPO3 4.5.16 to 4.5.26 but it throws an error in FE:
The error:

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/p.querner/public_html/xxxx/typo3_src-4.5.26/typo3/sysext/extbase/Classes/Persistence/Storage/Typo3DbBackend.php on line 854 Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/p.querner/public_html/xxxx/typo3_src-4.5.26/typo3/sysext/extbase/Classes/Persistence/Storage/Typo3DbBackend.php on line 854 Parse error: syntax error, unexpected T_STRING in /home/p.querner/public_html/xxxx/typo3_src-4.5.26/typo3/sysext/extbase/Classes/Persistence/Storage/Typo3DbBackend.php on line 854 >

In line 854 of said file is this:

throw new \TYPO3\CMS\Extbase\Persistence\Generic\Exception\InconsistentQuerySettingsException('Missing storage page ids.', 1365779762);

I changed it to

throw new TYPO3_CMS_Extbase_Persistence_Generic_Exception_InconsistentQuerySettingsException('Missing storage page ids.', 1365779762);>

And it seems to be working fine. (5 minutes testing, FE and BE)

Please have a closer look at this, because I dont know why exactly it caused the problem. My guess is because of namespace which isnt available in PHP 5.2.
I did not test the code on PHP 5.3 systems.

History

#1 Updated by Christian Kuhn over 6 years ago

  • Status changed from New to Accepted
  • Complexity changed from medium to easy

#2 Updated by Christian Kuhn over 6 years ago

  • Status changed from Accepted to Closed

Duplicate of #47978, will be fixed there.

Also available in: Atom PDF