Bug #48009

feUser should not be initialized when "Disable login" is set

Added by Philipp Bergsmann over 6 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2013-05-07
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After setting "Login Behaviour" to "Disable login" in the page-settings TYPO3\CMS\Frontend\Controller\TypoScriptFrontendController::initFEuser should not be called, because fe-user-handling is obviously (recursively) disabled.

History

#1 Updated by Thorsten Kahler over 6 years ago

  • Status changed from New to Rejected

The FE user has to be initialized before TYPO3 can determine wich pages are accessible. Without FE user it's not possible to determine if the page where you set "Disable login" is a parent page of the requested page.

See file source:typo3/sysext/cms/tslib/index_ts.php.

Also available in: Atom PDF