Bug #49293

forceAbsolutUrl sets always http as protocol if url_scheme is "default" - not the active protocol

Added by Ferdinand Kuhl about 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-06-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The field "url_scheme" in pages has three options "default" (means: Both of them, build as it is now, http: always http, https: always https).

But if you use forceAbsoluteUrl at a default page which has "default" as option and is called per https the link will be generated with "http".

#1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/21540

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21589

#3

Updated by Ferdinand Kuhl almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Christoph Gross almost 8 years ago

Current Patch broke Typo3 6.2 because of t3lib_div depreciation:

PHP Fatal error: Class 'TYPO3\\CMS\\Frontend\\ContentObject\\t3lib_div' not found in /var/www/typo3/versions/typo3_src-6.2-master-2013-11-09/typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php on line 6096

https://git.typo3.org/Packages/TYPO3.CMS.git/commitdiff/cbc6672fad5075a1b569a01e3380f98d286bc69f

Should be GeneralUtility::getIndpEnv('TYPO3_SSL') on line 6096

#5

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF