Bug #49297

Extension Upload with ExtManger should delete complete Folder, else Fatal Error

Added by Sven Juergens over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-06-20
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

there are some Problems, if you upload an extension with Extensiomanager. The Option "Overwrite any existing extension!" should deleted all existing files or better the complete folder.
in my case, i have a mix out of two Extension Versions.

Steps to reproduce:

- install a fresh TYPO3 4.7.12 and then static_info_tables

If you now want to install static_info_tables you got this warning "The running TYPO3 version (4.7.12) is lower than required (6.0.6)." 
Ok, now go to TER and Download the latest version for 4.7.x --> http://typo3.org/extensions/repository/download/static_info_tables/2.3.2/t3x/
And use the Upload Function in Extensionmanager and Check "Overwrite any existing extension!:" After Upload an Install you have BOTH extensions static_info_table 6 and 2 in one folder. And in this Moment the system crash because version 6 has an ext_autoload.php with 'TYPO3\CMS\Core\Utility\ExtensionManagementUtility' which result in a Fatal error.

Related issues

Duplicated by TYPO3 Core - Bug #48552: Unable to install static_info_tables in 4.7.12 EM Closed 2013-05-26

History

#1 Updated by Knut Behrends about 6 years ago

Sven Juergens wrote:

Hi,

there are some Problems, if you upload an extension with Extensiomanager. The Option "Overwrite any existing extension!" should deleted all existing files or better the complete folder.
in my case, i have a mix out of two Extension Versions.

Steps to reproduce:

- install a fresh TYPO3 4.7.12 and then static_info_tables

If you now want to install static_info_tables you got this warning "The running TYPO3 version (4.7.12) is lower than required (6.0.6)."
Ok, now go to TER and Download the latest version for 4.7.x --> http://typo3.org/extensions/repository/download/static_info_tables/2.3.2/t3x/
And use the Upload Function in Extensionmanager and Check "Overwrite any existing extension!:" After Upload an Install you have BOTH extensions static_info_table 6 and 2 in one folder. And in this Moment the system crash because version 6 has an ext_autoload.php with 'TYPO3\CMS\Core\Utility\ExtensionManagementUtility' which result in a Fatal error.

I was affected by this, too. I had updated an existing version of static_info_tables. The extension manager just showed a hint, an icon indicating "There is an update available" I just updated it. Not sure if there was a warning dialog in my case.

To anyone who needs help fixing this:

I removed the typo3conf/ext/static_info_tables directory and restored it from a backup.

You can also prevent loading the extension by editing typo3conf/localconf.php. Remove 'static_info_tables' from the comma separated list on the right side of the assignments to $TYPO3_CONF_VARS['EXT']['extList'], $TYPO3_CONF_VARS['EXT']['extList_FE'].

#2 Updated by Camelia M about 6 years ago

You can also prevent loading the extension by editing typo3conf/localconf.php. Remove 'static_info_tables' from the comma separated list on the right side of the assignments to $TYPO3_CONF_VARS['EXT']['extList'], $TYPO3_CONF_VARS['EXT']['extList_FE'].

I also have this problem, but the above did not work for me. I removed static_info_tables from everywhere in LocalConfiguration.php, clear cache, completely empty typo3temp folder but still I get the error with "Failed opening required ClassCacheManager.php in ext_autoload.php on line 7" when I try to access extension manager. I even tried completely removing the folder extension. Still it did not work. This is very weird to me as I am not aware of any other place where cache could be located.

#3 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Taken into account in #63909.
The issues are not linked on purpose, so the refactoring ticket does not get bloated with relations.

Also available in: Atom PDF