Bug #49601

f:form tag shown as a HTML on frontend

Added by Jignesh Prajapati almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-07-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.5
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

Hello guys,

I have one problem using the f:form tag
I integrated the template using the FLUIDTEMPLATE in Typo3 version 6.1
Now i created one extension that simply show the the form with two input elements. I used the f:form and f:form.textfield to display the form. Now problem is that whole form shown as HTML tags instead of real form. Please see the attached screenshot.

However, when i used the same extension using the templavoila in Typo3 version 6.1 then everything is working fine.

I am using below typoscript for FLUIDTEMPLATE integration.

Create a Fluid Template
page.10 = FLUIDTEMPLATE
page.10.template = FILE
page.10.template.file = fileadmin/templates/index.html
[globalVar=TSFE:page|layout=1]
page.10.template.file = fileadmin/templates/home-products.html
[global]
[globalVar=TSFE:page|layout=2]
page.10.template.file = fileadmin/templates/products.html
[global]
[globalVar=TSFE:page|layout=3]
page.10.template.file = fileadmin/templates/product-details.html
[global]
[globalVar=TSFE:page|layout=4]
page.10.template.file = fileadmin/templates/products-img.html
[global]
[globalVar=TSFE:page|layout=5]
page.10.template.file = fileadmin/templates/settings.html
[global]
page.10 { # Set the Template Pathes
partialRootPath = fileadmin/templates/partials/
layoutRootPath = fileadmin/templates/layouts/
variables { # Assign the main column with our {content}-destination
content_main < styles.content.get # Assign the left column with our {content_left}-destination
content_left < styles.content.get
content_left.select.where = colPos = 1 # Assign the right column with our {content_right}-destination
content_right < styles.content.get
content_right.select.where = colPos = 2
left < styles.content.get
left.select.where = colPos=1
}
}

Not getting what happens with FLUIDTEMPLATE. Please help me as it is very urgent for me. Any help will be appriciated.

Thanks,
Jignesh


Files

form_tag.png (53.4 KB) form_tag.png Jignesh Prajapati, 2013-07-02 17:18
#1

Updated by Jignesh Prajapati almost 9 years ago

I am using below tag to render the main content into template

<f:format.html parseFuncTSPath="lib.parseFunc">{content_main}</f:format.html>

#2

Updated by Alexander Jahn almost 9 years ago

Try using

<f:format.html parseFuncTSPath="">{content_main}</f:format.html>

without "lib.parseFunc" or
<f:format.raw>{content_main}</f:format.raw>

#3

Updated by Jignesh Prajapati almost 9 years ago

Alexander Jahn wrote:

Try using
[...]
without "lib.parseFunc" or
[...]

Yes, It works for me.
Your help is really appreciated. Thank you very much.

#4

Updated by Jignesh Prajapati almost 9 years ago

  • % Done changed from 0 to 100
#5

Updated by Alexander Opitz almost 9 years ago

  • Status changed from New to Closed

Also available in: Atom PDF