Bug #50531

Deleted state is not persisted in file objects

Added by Oliver Hader almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Won't have this time
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-07-29
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

The deleted state of file objects of the file abstraction layer is not persisted and thus to carried to the database.
Since the concept of using the deleted flag is not used at all, additional checks and processors to set and unset the state need to be integrated.


Related issues

Related to TYPO3 Core - Bug #48336: sys_file record doesn't get flagged as delete after deleting a file Rejected 2013-05-17
Related to TYPO3 Core - Task #50876: Handling of deleted files in FAL Closed 2013-08-06

History

#1 Updated by Oliver Hader almost 6 years ago

Since issue #48336 has been reverted due to regressions, this is the next try to get it integrated correctly and modify the affected components of the file abstraction layer.

#2 Updated by Ernesto Baschny almost 6 years ago

  • Status changed from New to Needs Feedback

We now have the "missing" flag which is more semantically correct. The "deleted" flag should be dropped as decided in Mainz (#51562). So this issue here is obsolete, right, Olly?

#3 Updated by Frans Saris almost 6 years ago

This issue can be closed

#4 Updated by Oliver Hader almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Priority changed from Should have to Won't have this time
  • Is Regression set to No

Correct, since we have the missing file state, this one is obsolte.

Also available in: Atom PDF