Bug #51867

TSconfig for page in workspace (mod.web_list.allowedNewTables)

Added by Jakob Berlin about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2013-09-09
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If you have a page with a special TSconfig setup for inserting only content of a specific table (mod.web_list.allowedNewTables) and you have workspace version of that page where the setting is not setup (e.g. no setup in TSconfig column at all) then in the live workspace the setup from TSconfig of the workspace version is used (e.g. no config at all).
This results in a listing of all available content elements in live workspace instead of only content elements from the specified tables.

  1. Create a page and setup mod.web_list.allowedNewTables in TSconfig section.
  2. Goto workspace and setup something else for the page so a workspace version of the page will be created. May also remove the TSconfig setting for the page in the workspace.
  3. Switch back to the live workspace.
  4. Add content by clicking the icon on the top -> Now not only the configured tables are listed. Everything is listed instead.

TODO: Use TSconfig setup of current workspace version of page.

History

#1 Updated by Ernesto Baschny about 6 years ago

  • Status changed from New to Needs Feedback

I could not reproduce that. In step 3 going back to "live mode" I still get the restriction on the tables that was active in the live mode before (regardless of what I did in my draft workspace). Also as expected in the draft workspace as soon as I lifted the restriction again I could add every table (only in the draft workspace).

Maybe you published your workspace in between?

#2 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF