Bug #52687

Support ip mask for localhost mysql connections

Added by Nicole Cordes over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Install Tool
Target version:
Start date:
2013-10-11
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently the hostname is checked for localhost or 127.0.0.1 only for local mysql connection host. But as specified in RFC 790 all ip addresses with mask 127.x.x.x are considered to be on localhost. So the install tool should be able to handle ip addresses starting with 127. as localhost.

Associated revisions

Revision 681d2565 (diff)
Added by Nicole Cordes over 6 years ago

[BUGFIX] Improve database connection smooth migration wizard

This patch adds support for local database connections over ips applying
to mask 127.xxx.xxx.xxx as specified in RFC 790. Additionally the
support for non local host connections is improved by setting a default
port independent from host name.

Resolves: #52687
Releases: 6.2
Change-Id: I2ddde8241003b78aee8a196ed4bd5dd78e3d20cb
Reviewed-on: https://review.typo3.org/24553
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Alexander Opitz
Tested-by: Alexander Opitz
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Nicole Cordes over 6 years ago

There is a problem even with hostnames other than localhost or 127.0.0.1 because no default port is set during smooth migration process!

#2 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24553

#3 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24553

#4 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24553

#5 Updated by Nicole Cordes over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF