Project

General

Profile

Actions

Bug #52955

closed

"new page drag area" did not recognize labels of new page doktypes

Added by Caspar Stuebs over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
Start date:
2013-10-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

If you add a new page doktype and add it to the "new page drag area" in the page tree, the label of the new doktype is not shown.

This is because the label map array in the ExtdirectTreeDataProvider is hardcoded.

File: typo3/sysext/backend/Classes/Tree/Pagetree/ExtdirectTreeDataProvider.php
Function: getNodeTypes()
Line: 115ff

Solution:
Get the label map array from TCA.


Files

Actions #1

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24934

Actions #2

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/24934

Actions #3

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27704

Actions #4

Updated by Caspar Stuebs over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF