Bug #53075

Bug #50881: Fix 4.5/4.7 missing autoloaded classes (i.e. backend_cacheActionsHook)

Do not auto-load SC_* classes

Added by Ernesto Baschny almost 6 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Category:
Backend API
Target version:
-
Start date:
2013-10-23
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The SC_* classes contain runnable code, and thus cannot be "auto-loaded". This was discovered due to crashes in the phpunit tests for 4.7 (by travis).

So fixing this will also fix broken travis.

Associated revisions

Revision 37c4f0b9 (diff)
Added by Ernesto Baschny almost 6 years ago

[BUGFIX] Cannot auto-load SC_* classes

These script files cannot be auto-loaded because they also include
runnable code.

Resolves: #53075
Releases: 4.7, 4.5
Change-Id: Ib3a956b69355466016099e996b6ca6c5f89978cd
Reviewed-on: https://review.typo3.org/24978
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-by: Ernesto Baschny
Tested-by: Ernesto Baschny

Revision 5ae438c4 (diff)
Added by Ernesto Baschny almost 6 years ago

[BUGFIX] Cannot auto-load SC_* classes

These script files cannot be auto-loaded because they also include
runnable code.

Resolves: #53075
Releases: 4.7, 4.5
Change-Id: Ib3a956b69355466016099e996b6ca6c5f89978cd
Reviewed-on: https://review.typo3.org/24979
Reviewed-by: Ernesto Baschny
Tested-by: Ernesto Baschny

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/24978

#2 Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/24979

#3 Updated by Ernesto Baschny almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF