Bug #53641

Bug #51537: Add distribution management to extension manager

Get preconfigured distribution causes warning

Added by Nicole Cordes over 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2013-11-14
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If I open "Get preconfigured distribution" from extension manager menu I get a warning:

Warning: finfo::file(C:/Users/Nicole/Server/typo3-master.local/) [<a href='finfo.file'>finfo.file</a>]: failed to open stream: No such file or directory in C:\Users\Nicole\Version Control\Git\TYPO3\TYPO3.CMS\master\typo3\sysext\core\Classes\Resource\Driver\LocalDriver.php on line

This is because the extension icon for the distribution isn't found and an empty string from GeneralUtility::getFileAbsFileName is returned

Associated revisions

Revision e061ada2 (diff)
Added by Nicole Cordes over 6 years ago

[BUGFIX] Em: Get preconfigured distribution causes warning

This patch adds an early return for empty file name which happens if an
extension isn't installed.

Resolves: #53641
Releases: 6.2
Change-Id: I1cc3605bf5cddfd4e83c363b974a83d20172d0ce
Reviewed-on: https://review.typo3.org/25401
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25401

#2 Updated by Nicole Cordes over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Ernesto Baschny about 6 years ago

  • Parent task set to #51537

#4 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF