Bug #53759

Task #52965: Remove deprecated functions, classes and files

Deprecated function call set_magic_quotes_runtime

Added by Cynthia Mattingly over 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-11-19
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Result of php codesniffer for deprecated functions:

typo3_src-6.2.0beta1/typo3/contrib/pear/HTTP/Request2.php
------------------------------------------------------------------------------------------------------------------------
FOUND 2 ERROR AFFECTING 2 LINE
------------------------------------------------------------------------------------------------------------------------
949 | ERROR | Function set_magic_quotes_runtime() has been deprecated
964 | ERROR | Function set_magic_quotes_runtime() has been deprecated
------------------------------------------------------------------------------------------------------------------------

set_magic_quotes_runtime is deprecated since php 5.3.


Related issues

Related to TYPO3 Core - Task #62672: Update PEAR packages Closed 2014-11-04

History

#1 Updated by Markus Klein over 5 years ago

  • Category deleted (Miscellaneous)
  • Status changed from New to Accepted

Maybe an update of the HTTP library is necessary.

#2 Updated by Markus Klein over 5 years ago

  • Parent task set to #56772

#3 Updated by Markus Klein over 5 years ago

  • Parent task changed from #56772 to #52965

#4 Updated by Markus Klein over 4 years ago

  • Status changed from Accepted to Rejected
  • Target version deleted (6.2.0)

I checked the current version of the lib, but this code is still present there. But this will not cause trouble, because the usage is protected with a proper check.

Also available in: Atom PDF