Project

General

Profile

Actions

Bug #54015

closed

Class 'TYPO3\\CMS\\Install\\Status\\OkStatus' not found

Added by Andrea Schmuttermair about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2013-11-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello there,

I just tried to upgrade from 6.0 to the 6.2beta2, and I get this error from Install Tool:

PHP Fatal error: Class 'TYPO3\\CMS\\Install\\Status\\OkStatus' not found in /opt/typo/typo3_src-6.2.0beta2/typo3/sysext/install/Classes/SystemEnvironment/Check.php on line 145, referer: http://navidev4.v4.navi.nintendo-europe.com/typo3/backend.php

I checked, and the class is there. Obviously in the install process everything is OK because it tries to create the OK Status.

I suppose there is something wrong with namespaces?
My PHP Version is 5.3.22
I will get soon an upgrade to PHP 5.4, maybe the error disappears then.

But PHP requirement is currently set to everything above 5.3.7, so it should work.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #54148: Clear all caches not working properlyClosed2013-12-02

Actions
Actions #1

Updated by Andrea Schmuttermair about 10 years ago

Forgot to mention: in Browser I have URL https://www.myurl.de/typo3/sysext/install/Start/Install.php, and I get the 500 Internal Server Error and a white screen before any login or something.

Actions #2

Updated by Andrea Schmuttermair about 10 years ago

  • % Done changed from 0 to 100

Sorry for that...
I deleted all files in typo3temp folder and now it works. Deleted the folder at least 2 times before, but now it works.

Actions #3

Updated by Wouter Wolters about 10 years ago

  • Status changed from New to Closed
  • % Done changed from 100 to 0

Hi Andrea,

This looks indeed like a caching issue. A good thing is that the Install Tool now has a Clear Cache button which will also handle deleting the cache for the loading of classes.

typo3temp/Cache/ is a folder which holds these caches.

Actions

Also available in: Atom PDF