Bug #54132

TS Template causes Ajax-Error when saving to external file via TS-Editor

Added by Elmar Putz over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2013-12-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

Hi,

we have a setup, where all TS-Code is stored in external files but we are using the built-in-backend editor for editing the code ("Include Typoscript file content" is activated) . With the latest update to 6.1.6, it is no longer possible to save the code. We have re-checked the file permissions on the server, but the editor hangs on save and the file will not be updated.

Saving of TS code works again, when the "INCLUDE_TYPOSCRIPT" directives at the beginning and end of the code are removed.
Editing the files directly via external editor works too. We observed the saving operation with a javascript console and we found out, that the correspondant ajax request causes an "internal server error (500)". Exploring the server logs, we found the following entry caused by the operation:

[02-Dec-2013 12:02:19 Europe/Berlin] PHP Fatal error: Class 'TYPO3\CMS\Core\TypoScript\Parser\GeneralUtility' not found in ....../www/typo3_src/typo3_src-6.1.6/typo3/sysext/core/Classes/TypoScript/Parser/TypoScriptParser.php on line 895

Regards
Elmar Putz


Related issues

Related to TYPO3 Core - Bug #53195: T3editor: Honour fileDenyPattern on saving included TSClosed2013-10-29

Actions
Is duplicate of TYPO3 Core - Bug #54117: Typoscript Editor broken after update to 6.1.6Closed2013-12-01

Actions
#1

Updated by Markus Klein over 8 years ago

  • Status changed from New to Accepted
  • Target version set to next-patchlevel
  • TYPO3 Version changed from 6.1 to 6.0
  • Complexity set to no-brainer
  • Is Regression changed from No to Yes

Regression in 6.0 and 6.1.

Backport of #53195 didn't properly use the namespace for GeneralUtility

#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25877

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25878

#4

Updated by Markus Klein over 8 years ago

  • Status changed from Under Review to Closed

Duplicates #54117 and is solved there.

Also available in: Atom PDF