Bug #55016

Install tool fails to change 'setDBinit'

Added by Thomas Skierlo about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2014-01-15
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Latest Master 6.2.0, new install, no data

I was trying to enforce a collation on setDBinit via Install Tool/All configuration. Reason: #54952, #36754

Whatever I enter is confirmed:


$TYPO3_CONF_VARS['SYS']['setDBinit']
New value = SET NAMES utf8 COLLATE utf8_unicode_ci;

But it never makes it's way into “LocalConfiguration.php”. LocalConfiguration.php gets a new timestamp. That's all.

Same happens with a correct string (single ticks around values): SET NAMES 'utf8' COLLATE 'utf8_unicode_ci';


Related issues

Duplicates TYPO3 Core - Bug #41596: Content of $TYPO3_CONF_VARS['SYS']['setDBinit'] is completely overruled / ignored Closed 2012-10-04

History

#1 Updated by Markus Klein about 6 years ago

  • Status changed from New to Closed

Thomas, the fix for this is almost merged.
Please test and vote on https://review.typo3.org/15369

Closing this as duplicate of #41596

Also available in: Atom PDF