Bug #55666

Thumbs in FAL have very big sizes

Added by Thomas Kakuschke about 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-02-04
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In FAL the Thumbnails have the original image width, even when the image have 3000 Pixel, that the whole Backend is overfloating.

It is not realy possible to work with this.

TYPO3FALBigThumbs.jpg View (313 KB) Thomas Kakuschke, 2014-02-05 20:52


Related issues

Related to TYPO3 Core - Bug #51768: IRRE - drag and drop sorting of items not possible in Internet Explorer Closed 2014-04-20

History

#1 Updated by Thomas Kakuschke about 6 years ago

The Problem happend in beta5

#2 Updated by Frans Saris about 6 years ago

  • Status changed from New to Needs Feedback

You talking about the thumbs shown when you edit a text + images content element?

#3 Updated by Thomas Kakuschke about 6 years ago

Maybe it can help with a screenshot

#4 Updated by Frans Saris about 6 years ago

I think the problem is the '45c' value in InlineElement.php.
https://review.typo3.org/#/c/27164/10/typo3/sysext/backend/Classes/Form/Element/InlineElement.php

Could you test this by removing the 'c'?

Gr. Frans

#5 Updated by Thomas Kakuschke about 6 years ago

I've removed the 'c'. Nothing changed.

FYI: The Thumbs in beta4 were ok.

#6 Updated by Thomas Kakuschke about 6 years ago

In "typo3/sysext/backend/Classes/Form/Element/InlineElement.php" Line 599 is a Problem with CONTEXT_IMAGECROPSCALEMASK. I replaced it with the old (from beta4) CONTEXT_IMAGEPREVIEW, and it works.

599: $imageUrl = $fileObject->process(\TYPO3\CMS\Core\Resource\ProcessedFile::CONTEXT_IMAGEPREVIEW, $imageSetup)->getPublicUrl(TRUE);

Can somebody take a look in the Code and fix it, i am not the best php developer.

I hope it will help ;-)
Thomas

P.S. Please set Priority to Must have.

#7 Updated by Frans Saris about 6 years ago

Could you check if cropping works for you at all?

#8 Updated by Thomas Kakuschke about 6 years ago

Cropping in Frontend works perfect

#9 Updated by Frans Saris about 6 years ago

  • Status changed from Needs Feedback to Accepted
  • Assignee set to Frans Saris
  • Priority changed from Should have to Must have

Image processing context has changed from preview (backend use) to cropScale (frontend use) this should be reverted.

But I'm not sure why this results in the problems you describe.

#10 Updated by Helmut Hummel about 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Priority changed from Must have to Could have

Frans Saris wrote:

Image processing context has changed from preview (backend use) to cropScale (frontend use) this should be reverted.

Not sure why this should be reverted. I'm more interested in finding out the reason why this fails, because we will need cropScale for RTE.
I'm also not sure why cropScale should only be dedicated to frontend use only.

But I'm not sure why this results in the problems you describe.

@Thomas: please try to tuncate sys_file_processedfile
If this does not help, please tell us more about your environment: what PHP version, what image magic or graphics magic configuration etc.

Thanks

#11 Updated by Frans Saris almost 6 years ago

  • Assignee deleted (Frans Saris)

#12 Updated by Thomas Kakuschke over 5 years ago

I dont have this Problem anymore. I dont know why. Get Luck ;-)

I think this Task can be closed.

#13 Updated by Frans Saris over 5 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF