Bug #55794

jquery-ui is missing theme

Added by Marcin Sągol almost 7 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-02-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

We are using jquery-ui in the backend in several places. JavaScript file is loaded from /typo3/contrib/jqueryui/jquery-ui-1.10.4.custom.min.js but it is missing theme files (css, images etc.). This results for example with invisible sorting indicators in Extension Manager. There are used valid jquery-ui classes:

<div class="DataTables_sort_wrapper">
Extension<span class="DataTables_sort_icon css_right ui-icon ui-icon-triangle-1-n"></span>
</div>

they are changed when sorting direction changes but we dont see the indicators because of missing theme!

We should add jquery-ui theme to backend assets.

#1

Updated by Benni Mack about 6 years ago

  • Status changed from New to Rejected

Hey,

for CMS 7, we included the latest jQuery UI version, but not all components. All visual elements are not used, rather Twitter Bootstrap components for this.

Additionally, datatables is now updated to 1.10, which includes its own themeing which probably be included in CMS 7 at a later stage.

So: No Support for jQuery UI themes in the core, please include it in your own extension if you need it.

Also available in: Atom PDF