Project

General

Profile

Actions

Bug #55896

closed

No FE Editing icons, if the admPanel is disabled

Added by Tim Lochmüller over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-02-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hey guys,

I have the problem, that I have no FE Editing icons (in the FE editing panel next to the content elements), if the admPanel ist disabled.
I patch the index_ts to load the admin_panel CSS file, if the AdmPanel OR the FE Editing is active.

Please check the patch...

Regards,
Tim


Files

screen.jpg (214 KB) screen.jpg Tim Lochmüller, 2014-03-22 12:09
Actions #1

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27557

Actions #2

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27557

Actions #3

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27557

Actions #4

Updated by Gerrit Code Review over 10 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27557

Actions #5

Updated by Gerrit Code Review over 10 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27557

Actions #6

Updated by Nicole Cordes over 10 years ago

@tding

We checked your issue and asked ourselves if you use the core extension "feedit" or any third party extension. According to guidelines (http://wiki.typo3.org/Frontend_editing) it isn't possible to use frontend editting without the adminPanel. And if the admin panel isn't shown the CSS file isn't needed at all. If you use another extension please submit the bug report over there because it has to include the CSS file then.

We reworked the core feedit to be visible even when the adminPanel is minimized (but still enabled) so the icons are shown.

Hope this helps you a little bit.

Actions #7

Updated by Tim Lochmüller over 10 years ago

The screent attached show the problem. I use the normale feedit with this configuration TSConfig:

admPanel {
enable.edit = 1
override.edit {
displayIcons = 1
displayFieldIcons = 1
}
}

and TypoScript Setup with config.admPanel = 0.

The complete edit-panel & the icon after the headline (this icon is visable) is rendered in the HTML, but there are no icons (visable). If you know, where the icons are, it is possible to click in the white are to use the functions ;) The patch set 5 doesn't solve the problem...

Regards,
Tim

Actions #8

Updated by Tim Lochmüller about 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF