Bug #56035

Editing file properties fails for backend users (non-admin)

Added by Nicole Cordes over 6 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-02-17
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As an admin you can't edit files over clickmenu because the metadata uid is not set correctly. As an editor currently there is no chance to edit files.

Associated revisions

Revision b2f804f0 (diff)
Added by Nicole Cordes over 6 years ago

[BUGFIX] Load file meta data properties before return

Currently it is not possible to edit files as an editor because no file
uid is submitted. This happens because meta data properties are not
loaded. This patch makes sure they get loaded before returning them.

Resolves: #56035
Releases: 6.2
Change-Id: I610aa50d785ea22cd1f0bc6265369cccf5bdd719
Reviewed-on: https://review.typo3.org/27652
Reviewed-by: Michiel Roos
Reviewed-by: Steffen Ritter
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27652

#2 Updated by Nicole Cordes over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF