Project

General

Profile

Actions

Bug #56240

closed

sys_file_metadata does used TCA-types but no type column exists

Added by Martin Ficzel almost 10 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2014-02-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

FAL-Records have a type-property which is between 0-5 (unknown, text, image, audio, video, software) that is stored in the sys_file table.

The sys_file_metadata table uses a type-property which is not existing in sys_file_metadata to switch between the different TCA-Types. This seems to be an artifact of the extraction of sys_file_metadata from sys_file to me.

The TCA types of sys_file_metadata should switch based on the type in the referenced sys_file record or the type should be mirrored into sys_file metadata.

Actions #1

Updated by Martin Ficzel almost 10 years ago

  • Target version changed from 6.2.0 to next-patchlevel
Actions #2

Updated by Martin Ficzel almost 10 years ago

This is resolved current master. The type feature is removed from core and was moved to ext:filemetadata where it works again because it now uses ['ctrl']['type'] = 'file:type' instead of ['ctrl']['type'] = 'type'.

Please close this issue. Thanks, Martin

Actions #3

Updated by Mathias Schreiber about 9 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF