Project

General

Profile

Actions

Bug #56283

closed

TCA::addFieldsToPallette removes field from list

Added by Philipp Wrann almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2014-02-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

This command:
$list = $newList = trim($list, ', \\t\\n\\r\\0\\x0B');

causes exiting fields to be removed, when executing
\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addFieldsToPalette();

which calls
\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::executePositionedStringInsertion();

this also happens when doing
\TYPO3\CMS\Core\Utility\ExtensionManagementUtility::addFieldsToPalette('pages','title','');

WORKS: $list = $newList = trim($list)
WORKS: $list = $newList = trim($list, ", \t\n\r\0\x0B");
DOES NOT WORK: $list = $newList = trim($list, ', \\t\\n\\r\\0\\x0B');

PHP Version is 5.3.10


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #56080: Title field gets lost after using addToAllTCAtypesClosed2014-02-18

Actions
Actions #1

Updated by Markus Klein almost 10 years ago

  • Status changed from New to Closed

Duplicates #56080

Actions

Also available in: Atom PDF