Bug #56892

FunctionalTestCaseBootstrapUtility throws Warnings

Added by Nicole Cordes about 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Tests
Target version:
Start date:
2014-03-13
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

unlink can't delete symlinks on Windows systems.

Associated revisions

Revision 9f4f9c4f (diff)
Added by Nicole Cordes about 6 years ago

[BUGFIX] FunctionalTestCaseBootstrapUtility throws warnings on Windows

If the FunctionalTestCaseBootstrapUtility::removeInstance() tries to
delete an existing symlink to a folder, the function unlink() is used.
This leads to a warning on Windows systems because unlink can only
delete files and symlinks to files.
This patch adds a rmdir() call for symlinks which works for Windows
system as well.

Resolves: #56892
Releases: 6.2
Change-Id: I2de757daea89a65a0a631c7592287e16218c1452
Reviewed-on: https://review.typo3.org/28371
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

History

#1 Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28371

#2 Updated by Nicole Cordes about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF