Bug #56952

Extension checker not working anymore since PackageManagement performance

Added by Ernesto Baschny over 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Install Tool
Target version:
Start date:
2014-03-16
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since merging of 64c46b918ef016bdd1d799c5ca06e868d601f692 (Package management performance improvements), TYPO3_LOADED_EXT is no longer an ArrayAccess but a regular array (like pre 6.2). This leaded to an error in the Extension Manager important action "Check Extension", causing an endless loop.

The error in the Ajax requests:

Catchable fatal error: Argument 2 passed to TYPO3\CMS\Install\Controller\Action\Ajax\ExtensionCompatibilityTester::loadExtLocalconfForExtension() must implement interface ArrayAccess, array given

Associated revisions

Revision 095ae8e8 (diff)
Added by Ernesto Baschny over 5 years ago

[BUGFIX] Check extensions in Install Tool broken

Since merging of 64c46b918ef016bdd1d799c5ca06e868d601f692, TYPO3_LOADED_EXT
is no longer an ArrayAccess but a regular array (like pre 6.2). This leaded
to an error in the Extension Manager important action "Check Extension",
causing an endless loop.

Catchable fatal error: Argument 2 passed to
TYPO3\CMS\Install\Controller\Action\Ajax\ExtensionCompatibilityTester
::loadExtLocalconfForExtension() must implement interface ArrayAccess,
array given

Resolves: #56952
Releases: 6.2
Change-Id: I02e83a8221653d62010952f84c17a8f6f6e185ea
Reviewed-on: https://review.typo3.org/28437
Reviewed-by: Ernesto Baschny
Tested-by: Ernesto Baschny

History

#1 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28437

#2 Updated by Ernesto Baschny over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF