Bug #57244

AbstractDomainObject: _getCleanProperties() may return NULL instead of an array

Added by Thomas Hucke about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2014-03-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

6.2.0rc1:
PHP Warnings will be generated in some cases due to that issue.
Attached patch will solve that.
An empty array() will now be returned instaed of NULL
Thanks


Files

AbstractDomainObject.patch (121 Bytes) AbstractDomainObject.patch Thomas Hucke, 2014-03-24 18:47
#1

Updated by most wanted about 7 years ago

Thomas Hucke wrote:

PHP Warnings will be generated in some cases due to that issue.

do you have some details about those situations?

#2

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29814

#3

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29814

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29814

#5

Updated by most wanted about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF