Bug #57265

Importing large amounts of data issues many truncate's

Added by Philipp Gampe almost 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Performance
Target version:
-
Start date:
2014-03-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

While importing large amounts of data (e.g. while installing a distribution), \TYPO3\CMS\Core\DataHandling\DataHandler::clear_cache() is called for each record.
clear_cache() in turn tries to clean each related page frontend cache and finally (because of the default setting) deletes the cache group pages.

This results in some 10000 truncate calls being issued to the database.


Related issues

Is duplicate of TYPO3 Core - Bug #52235: Timeout when copying pages recursively due to cache-clearing overloadClosed2013-09-24

Actions
#1

Updated by Philipp Gampe almost 7 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF