Bug #57876

Extension Manager crashes on extension update with extension dependency

Added by Gautam K. about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2014-04-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

See exception attached (/typo3/mod.php?M=tools_ExtensionmanagerExtensionmanager&moduleToken=ecbb681246891a71157b589f8573c7fd904db51d&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Bextension%5D=pagebrowse&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Bformat%5D=json&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Baction%5D=updateExtension&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Bcontroller%5D=Download).

Error: #1382276561: The package "mm_forum" depends on "pagebrowse" which is not present in the system. (More information)

Steps to reproduce:
- Installation with TYPO3 6.2.0, mm_forum 1.9.2 and pagebrowse 1.3.3 installed.
- Go to Ext. Manager, download the latest TER, update pagebrowse to 1.3.4
- White page - no error (exception with error 500 thrown)

Seems like uninstalling the extension for updating crashes TYPO3 due to mm_forum's dependency on it.


Files

TYPO3_Exception.html (15.8 KB) TYPO3_Exception.html Gautam K., 2014-04-13 15:54

Related issues

Is duplicate of TYPO3 Core - Bug #57264: Extension manager fails to update extensions that are needed by other extensionsClosed2014-03-25

Actions
#1

Updated by Gautam K. about 7 years ago

Again, as with the other bugs I've reported on the ext. manager dependency checks, this does not occur when uploading a t3x file.

#2

Updated by Markus Klein about 7 years ago

  • Status changed from New to Closed

Closing as duplicate of #57264

Also available in: Atom PDF