Bug #58418

Error when retrieving extension list in Developer Mode

Added by Sascha Wilking about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-05-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When retrieving extension list in Extension Manager in Developer Mode, an Exception "Illegal string offset "kind" in "../AbstractExtensionXmlParser.php" is thrown.

In Production mode the Exception is not called, because a php warning only in development mode throws an Exception.

#1

Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29783

#2

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29783

#3

Updated by Sascha Wilking about 7 years ago

Description of PHP xml parser bug:

https://bugs.php.net/bug.php?id=66084

#4

Updated by Gerrit Code Review about 7 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29784

#5

Updated by Sascha Wilking about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF