Bug #58658

sys_action don't set password

Added by André Steiling over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-05-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've got a v6.2 installation and set up a sys_action to create BE users. I use the 3rd party extension be_secure_pw (v6.2.0) for stronger passwords, saltedpasswords and rsaauth are activated by default and work well, but if I use my sys_action to create a new user, the database field "password" in table be_users is empty for the new created user. Seems to be a bug, ya?

Second, saltedpassword logic isn't implemented in sys_action. This would be nice, especially for extensions like be_secure_pw, which hook into the password generation.

My system:

- TYPO3 v6.2.2
- saltedpasswords, rsaauth working
- taskcenter and sys_action v6.2.0
- be_secure_pw v6.2.0

#1

Updated by Markus Klein over 6 years ago

  • Status changed from New to Needs Feedback

What do you mean with "saltedpassword logic isn't implemented in sys_action"?
Does the task work if you disable be_secure_pw?

#2

Updated by André Steiling over 6 years ago

Hello Markus,

my fault! I didn't test it without having be_secure_pw disabled. Everything works fine without be_secure_pw - so it's a report for that extension. Could you move it to the project or should I create a new task?

The subtask about "saltedpassword logic" isn't relevant any more. Maybe I stood with one foot in the weekend last friday. ;)

#3

Updated by Markus Klein over 6 years ago

  • Status changed from Needs Feedback to Closed

Please file a new issue there. Thanks!

Also available in: Atom PDF