Bug #58699

IPv6 completely ignored by FE/BE lockIP

Added by Robotic-Brain no-lastname-given over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-05-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

I got the privacy extensions enabled on my system, which causes the IPv6 to change quite frequently.
But the ['BE']['lockIP'] setting is useless for IPv6. So Typo3 throws me out of the backend if the IP changes.

I would propose to add an additional config value only for IPv6 addresses (['BE']['lockIPv6'] and ['FE']['lockIPv6'])

some changes i managed to trace back:

sysext/core/Classes/Core/Bootstrap.php -> initializeBackendUser()
sysext/core/Classes/Authentication/AbstractUserAuthentication.php -> ipLockClause_remoteIPNumber()

since IPv6 becomes more and more popular this becomes more and more of an issue


Related issues

Is duplicate of TYPO3 Core - Bug #21638: IP-lock not aware of IPv6Closed2010-08-06

Actions
#1

Updated by Markus Klein over 7 years ago

What is the difference to #21638 in this bug report?
Otherwise I tend to mark this a duplicate.

#2

Updated by Robotic-Brain no-lastname-given over 7 years ago

The other is more of a workaround and targeted at Typo3 4.7,
but I guess you could call this a duplicate...

the problem still is, that you might want different rules for IPv4/IPv6

#3

Updated by Markus Klein over 7 years ago

Ok closing this as duplicate of #21638. Please consider to watch the other issue.

#4

Updated by Markus Klein over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF