Project

General

Profile

Actions

Bug #59158

closed

Does an uncached content element break the template?

Added by Philipp Wrann over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
Start date:
2014-05-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In one of my TYPO3 Installations i can not overrule the page title. When manipulating it and the page is served uncached (first-hit) i get the correct page title. But when the Page is regenerated from the cache the pagegenerator runs a process to insert the pagetitle, scripts etc... This happens when an uncached plugin or some INT Object is present on that page. In that case the overwritten page title gets lost and the original one (from the pages record/typoscript config) is inserted.

It seems that the hash in those template marks does not match the cHash saved for that page.

concrete example: place tx_news detail plugin on one page and some uncached plugin (indexed_search box or something). When you request that page with a specific news item the first hit is like expected. But when reconstructing the page from cache the title gets lost.

The same problem exists in my extension, i set the page title very similar and i understand that way to be convention.

Discussion:
http://forum.typo3.org/index.php/m/712068/#msg_712068

Can someone confirm this behaviour?

Actions #1

Updated by Riccardo De Contardi almost 9 years ago

  • Status changed from New to Closed

I am not able to reproduce it with the latest version of TYPO3 (6.2.12) and news (3.1.0)

my test

1) in the page with news detail I added the felogin plugin (is USER_INT)
2) I create a news item and add something in the "Alternative title" field
3) in the frontend, detail page, the title tag is the content of "Alternative title"
4) after refreshing the page (or reload with ctrl+R), the title is the same.

I'll close this;
If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Actions

Also available in: Atom PDF