Project

General

Profile

Actions

Bug #59372

closed

Improve the formatting of help of the CommandController

Added by Stefano Kowalke over 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2014-06-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

With the command

/cli_dispatch.phpsh extbase help extensionapi:fetch

you will get this help

Fetch an extension from TER.

COMMAND:
  core_a_p_i:extensionapi:fetch

USAGE:
  /Volumes/HDD/Users/sok/Sites/TYPO3/www.introduction.dev/typo3/./cli_dispatch.phpsh ./cli_dispatch.phpsh extbase extensionapi:fetch [<options>] <key>

ARGUMENTS:
  --key                      extension key

OPTIONS:
  --version              the exact version of the extension, otherwise the
                       latest will be picked
  --location            where to put the extension. System = typo3/sysext,
                       Global = typo3/ext, Local = typo3conf/ext
  --overwrite           $overwrite overwrite the extension if it already exists
  --mirror                mirror to fetch the extension from. Run
                       extensionapi:listmirrors to get the list of all
                       available repositories, otherwise a random mirror will
                       be selected

The help text of the options is not aligned. This happens because the text is taken by Reflection from the PHP DocComment which use whitespaces to align the description of a variable.

/**
 * Fetch an extension from TER.
 *
 * @param string $key       extension key
 * @param string $version   the exact version of the extension, otherwise the latest will be picked
 * @param string $location  where to put the extension. System = typo3/sysext, Global = typo3/ext, Local = typo3conf/ext
 * @param bool   $overwrite overwrite the extension if it already exists
 * @param string $mirror    mirror to fetch the extension from. Run extensionapi:listmirrors to get the list of all available repositories, otherwise a random mirror will be selected
 *
 * @return void
 */
Actions #1

Updated by Gerrit Code Review over 9 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/30594

Actions #2

Updated by Stefano Kowalke over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #3

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF