Project

General

Profile

Actions

Bug #60171

closed

Recursive content crashes with Text / Pics element

Added by Antoine Bouet almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2014-07-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

For a single page, I needed to display the content of pages and subpages with this TS code :

lib.single_page = CONTENT
lib.single_page {
    table = pages
    select.orderBy = sorting
    renderObj = COA
    renderObj {
        10 = CONTENT
        10 {
            table = tt_content
            select {
                pidInList.field = uid
            }
            wrap = |
        }
        20 = CONTENT
        20{
            table = pages
            select{
                pidInList.field = uid
            }
            renderObj = COA
            renderObj{
                10 = CONTENT
                10 {
                    table = tt_content
                    select {
                        pidInList.field = uid
                    }
                    wrap = |
                }
            }
        }
    }
}

It works fine, but it crashes only when a text/pic element is found in a subpage (in the "20.10" of the COA).

I patch the problem changing the line 727 in /typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php :

if (is_array($old_conf) && count($old_conf)) {

with this line :
if (is_array($old_conf) && count($old_conf) && !empty($conf)) {

But there is maybe a better solution :)


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #61627: "Beside Text, Right" crashesClosed2014-09-16

Actions
Is duplicate of TYPO3 Core - Bug #61595: Possible error when static extension typoscript template is not encluded: Warning: array_replace_recursive(): Argument #1 is not an arrayClosed2014-09-15

Actions
Actions #1

Updated by Antoine Bouet almost 10 years ago

In a Text & Images content, if you choose "Beside Text, Right" or "Beside Text, Left", the front end crashes.

This patch corrects this problem too :)

Actions #2

Updated by Markus Klein almost 10 years ago

  • Status changed from New to Closed

Closing as duplicate of #61595.
The bug is fixed there, please continue the discussion there.

Actions

Also available in: Atom PDF