Bug #60453

Copying page tree messes up image references

Added by Markus no-lastname-given over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-07-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have a large TYPO3 6.1.10 System with about 20 individual sites each consisting of about 30 pages. In regular intervals a new site is added by copying an existing site recursively and then renaming and editing it. The option for recursive copying in my user settings is set to 999.

Recently the copying is showing some odd behaviour:
After inserting the copied site after the last existing one, all image references are wrong. Every content element in the copied site is missing the images, while every content element in the original site has all images doubled. This doesn't seem to be just a bug in the backend display either: The images are shown two times in frontend too. Reloading or logging out and in again, clearing the cache, editing the content element and saving it - all doesn't help.
The strangest thing is: If I recursively delete the new site again all double images on the original site vanish.

Some weeks ago, this process worked almost fine: I had the described behaviour now an then, but when I deleted the new tree and started over again, it all worked. I thought it had maybe something to do with server load and php-scripts being killed before finishing (the copying takes several minutes). But trying to set the max-execution time to high values doesn't help.

I don't know what changed since it worked: The site grew, the TYPO3 System got updated several times, some extensions got updated.
Installed extensions: gridelements, realurl, news, formhandler

#1

Updated by Riccardo De Contardi over 5 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Markus no-lastname-given

Please, can you tell us if the bug is still present in the latest versions (6.2.12 or latest 7 master) ?
Thank you

#2

Updated by Markus no-lastname-given over 5 years ago

I can't test that right now, I'm sorry. The system I was talking about has not been updated to 6.2 yet and I don't administrate other 6.1 systems. I can report if we update it, but right now it looks as if it will rather be shut down in the near future.

#3

Updated by Riccardo De Contardi over 5 years ago

  • Status changed from Needs Feedback to Closed

seems fixed on the latest master, so I close it.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF