Bug #61007

Fluid partial is not rendered if folder with same name exists

Added by Hans Höchtl over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2014-08-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If the following file structure is present:

Resources/Private/Partials/Foo.html
Resources/Private/Partials/Foo/Bar.html

The partial Foo can not be rendered, because the search order for the partial is:

$paths = array(
  'Resources/Private/Partials/@partial',
  'Resources/Private/Partials/@partial.html'
);

And the function file_exists checks if the partial exists and the folder is the first one checked and returns true, so Fluid generates an empty rendered partial.

In TYPO3 CMS fluid/Classes/View/TemplateView.php:473

This relates to #39868


Related issues

Related to TYPO3 Core - Bug #61006: Fluid partial is not rendered if folder with same name existsClosed2014-08-16

Actions
#1

Updated by Anja Leichsenring over 7 years ago

  • Status changed from New to Closed

this is a duplicate of #61006

Also available in: Atom PDF