Bug #64953

dbType date and datetime fields are saved in wrong timezone

Added by Frans Saris about 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-02-10
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

All datefields are saved in UTC timezone throughout the core. But currently datefields of dbType date and datetime aren't saved correct. This becomes visible when you use the same fields in extbase.


Related issues

Related to TYPO3 Core - Feature #61110: Support for timezones in all date fields in TYPO3 BE New 2014-08-21
Related to TYPO3 Core - Bug #68849: Unstable persistence handling of DateTime (don't get what you set) Closed 2015-08-07
Related to TYPO3 Core - Bug #72878: wrong datetime handling, they are not UTC in db Closed 2016-01-21

History

#1 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36786

#2 Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36786

#3 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/36786

#4 Updated by Mathias Schreiber almost 4 years ago

  • Status changed from Under Review to Closed

dupe

Also available in: Atom PDF