Bug #65359

"includeJSFooterlibs" should be in lowerCamelCase, too

Added by Nicolas Scheidler over 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-02-26
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Based on the Deprecation #61605:

"page.includeJSlibs has been renamed to page.includeJSLibs to follow the lower camel case naming scheme." 

"page.includeJSFooterlibs" should be renamed to "page.includeJSFooterLibs".


Related issues

Related to TYPO3 Core - Bug #61605: Inconsistent naming of TypoScript key includeJSlibs Closed 2014-09-15

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40795

#2 Updated by Anja Leichsenring about 4 years ago

  • Status changed from Under Review to Rejected

rejected due to little gain contra lots of hassle for integrators. Once we have static code analysis in place (which is planned) we can come back to this kind of cleanup. Then we can rewrite TypoScript and other code on the fly without bothering the users.

Also available in: Atom PDF